Fork of mastodon_flutter (https://github.com/lukepighetti/mastodon_flutter). Uses pleroma_dart rather than mastodon_dart to interface with the Pleroma API
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 
Robby Zambito 452aa09400 Changed pleroma_dart url 4 weeks ago
example Bumped targetSdkVersion 1 month ago
lib Added LGPL. "Mastodon" -> "Pleroma" 1 month ago
test Added LGPL. "Mastodon" -> "Pleroma" 1 month ago
.gitignore flutter format on lib 8 months ago
.metadata first commit 1 year ago
CHANGELOG.md 0.3.1 Media widget updates (#9) 7 months ago
LICENSE-mastodon_flutter Added LGPL. "Mastodon" -> "Pleroma" 1 month ago
LICENSE.md Added LGPL. "Mastodon" -> "Pleroma" 1 month ago
README.md Added LGPL. "Mastodon" -> "Pleroma" 1 month ago
deploy.sh add example/lib to format 7 months ago
pubspec.yaml Changed pleroma_dart url 4 weeks ago

README.md

pleroma_flutter

A companion package to pleroma_dart that provides Flutter widgets to assist in developing a Pleroma Flutter client.

To see a complete Flutter Mastodon app, made with both mastodon_dart and this library, visit Jiminy for Mastodon.

Contributing

Create an issue, back it with a PR, and tag an active contributor.